SHOForum  


Go Back   SHOForum > Help and Maintenance - Gen 1 (89-91) & Gen 2 (92-95) > Gen 1 & 2 - Engine, Exhaust, Drive Line & AC systems

Reply
 
Thread Tools
  #1  
Old 05-16-2002, 10:38 PM
bradman bradman is offline
Registered
 
Join Date: Feb 2002
Location: Everett, WA
Posts: 314
bradman will become famous soon enough
HELP! Fan comes on when I turn the key on, but engine cold and no start.

I can't believe this! I just my 89 SHO out of the garage after replacing the inner tie rods and
two blocks down the road the car died. The fuel pump is not priming and the
fan is coming on as soon as I turn the key to the ON position, even though the engine is cold. It
did restart briefly but then died again, so I think that rules out the timing belt. It seems like I
had this problem once before when I didn't connect the extra wire to the positive battery
terminal, but it's all connected correctly now. Could a ground fault cause these symtoms?
I tried two other relay boxes and no change. I checked all the fuses except for the big silver
ones. I also thought it might be the CPS, but why would the fan come on and the fuel pump
not prime? I haven't pulled the codes because the fan would run during the whole process
and I don't want to kill the battery, AND the car is down the road a couple blocks.

Someone must have had this problem before. Any advice would be much appreciated.

<small>[ May 16, 2002, 10:43 PM: Message edited by: bradman ]</small>
Reply With Quote
  #2  
Old 05-17-2002, 09:30 AM
twr's Avatar
twr twr is offline
whoohoo
 
Join Date: Aug 2001
Location: half-way there, I think.
Posts: 2,131
twr is spectacular!twr is spectacular!twr is spectacular!
The fan coming on can mean only one thing - the pcm (computer) is not getting any power or it is not grounded properly. There is a black wire with a barrel shaped connector that grounds just behind the battery - make sure it has a good conection.
Terry
__________________
Terry
2008 Impreza STI, yeah it's already got a few modifications..
Reply With Quote
  #3  
Old 05-18-2002, 01:59 PM
bradman bradman is offline
Registered
 
Join Date: Feb 2002
Location: Everett, WA
Posts: 314
bradman will become famous soon enough
Thanks Terry.
I've checked all the grounds that I can find, including the one behind the battery, but I will go over it again. I hope it's not the PCM or the wire harness. BTW, PCM is another term for the EEC right?
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


If you wish to help keep SHOforum running please click the donation button below


All times are GMT -4. The time now is 09:03 PM.

Powered by vBulletin® Copyright ©2000 - 2008, Jelsoft Enterprises Ltd.
Style Provided By: Wrestling Clique - Wrestling Forums

All content Copyright 2000 - 2014, SHOForum.com
This forum is not affiliated with Ford Motor Company