SHOForum  


Go Back   SHOForum > Troubleshooting & Performance Upgrades - V8 (96-99) > V8 - Maintenance & Troubleshooting

Reply
 
Thread Tools
  #1  
Old 01-09-2012, 11:27 PM
jimtash's Avatar
jimtash jimtash is offline
Registered
 
Join Date: Dec 2001
Location: nc
Posts: 1,146
jimtash is spectacular!jimtash is spectacular!
Default Check engine light flashing on and off while driving/rotten egg smell in exhaust

Just started a few minutes ago while coming home. A misfire is there and I'm thinking bad coil or coils. Anything else to consider?
Reply With Quote
  #2  
Old 01-09-2012, 11:40 PM
Ishodu's Avatar
Ishodu Ishodu is offline
Moderator
 
Join Date: Jun 2002
Location: Hanover Ontario Canada
Posts: 5,079
Ishodu is a splendid oneIshodu is a splendid oneIshodu is a splendid oneIshodu is a splendid oneIshodu is a splendid oneIshodu is a splendid oneIshodu is a splendid oneIshodu is a splendid one
Default

The CE light has some info for you. You just need to get that info via code reader. I would start there.
__________________
95 MTX
3.2 High Comp forged pistons and Custom Cams plus more.
312hp 266tq
Drag Vid


Reply With Quote
  #3  
Old 01-09-2012, 11:48 PM
jimtash's Avatar
jimtash jimtash is offline
Registered
 
Join Date: Dec 2001
Location: nc
Posts: 1,146
jimtash is spectacular!jimtash is spectacular!
Default

Well of course but I've never experienced it when it continuously flashes on and off. Don't really want to drive it but I'll definitely get them pulled somehow.

Last edited by jimtash; 01-09-2012 at 11:49 PM.
Reply With Quote
  #4  
Old 01-12-2012, 05:17 PM
sandrew sandrew is offline
Registered
 
Join Date: Mar 2003
Location: Omaha, NE
Posts: 279
sandrew will become famous soon enoughsandrew will become famous soon enough
Default

Constant flashing is an active misfire.
__________________
OLD: 1996 TR / gray
Welded, Magnaflow Y-pipe, 3rd cat delete, no secondaries, no intake silencer, Paul Nimz tune
NEW: 1995 Mercury Cougar XR-7 4.6
Proverbial "Little Old Lady" 1-owner California car w/91k
There's no rust ANYWHERE...I almost don't know what to do with myself. ;)
Reply With Quote
  #5  
Old 01-14-2012, 01:46 PM
jimtash's Avatar
jimtash jimtash is offline
Registered
 
Join Date: Dec 2001
Location: nc
Posts: 1,146
jimtash is spectacular!jimtash is spectacular!
Default

Number 4 coil went bad. Replaced it and all is back to normal.
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


If you wish to help keep SHOforum running please click the donation button below


All times are GMT -4. The time now is 04:35 PM.

Powered by vBulletin® Copyright ©2000 - 2008, Jelsoft Enterprises Ltd.
Style Provided By: Wrestling Clique - Wrestling Forums

All content Copyright 2000 - 2014, SHOForum.com
This forum is not affiliated with Ford Motor Company