Who Sells These Econo Power Junk Batteries?

Discussion in 'Gen 1 & 2 - Electronics & Audio' started by JRA2000TL, Dec 27, 2010.

  1. JRA2000TL

    JRA2000TL The Complainer

    Joined:
    Dec 29, 2006
    Messages:
    1,665
    Likes Received:
    712
    Occupation:
    Internal Auditor
    Location:
    Daphne, AL
    I have one in my 95 thanks to the PO. I have constant issues with it. When I'm working on the car and the hood light and interior lights are on for as little as 30 min. or so, this thing runs down. Seems like I have to constantly jump it off. I know that with the autolamp, the fact the headlights stay on for a bit when the car is off also contributes to some battery usage.

    The reason I ask is because it's punched out July 2010, so it's a new battery...are they just "that" crappy? I assume so being "econo" power. I did some reading and it looks like they are reconditioned Interstate Batteries.

    I don't really have the extra hundred bucks right here after Christmas, but I think I may have to junk this one soon and get something else.
     
  2. tompumped

    tompumped SHO Member

    Joined:
    Jan 14, 2006
    Messages:
    486
    Likes Received:
    56
    Location:
    VT
    They are crap. When I bought the sho I drive now it came with one. I have to say I did make it home on just the battery. It didn't seem to last very good for long though. Like you said it stopped holding a charge, but it still worked. It would just drain down fast, and crank slow.
    Since then I ran into Napa's the legend. The reserve cranking is the longest lasting i've ever seen.
     
  3. SHOclass

    SHOclass Conan has one

    Joined:
    Feb 3, 2010
    Messages:
    237
    Likes Received:
    106
    Occupation:
    Sales Consultant
    Location:
    S. Windsor, Connecticut
    X2 on the NAPA legend batteries
     
  4. RonPorter

    RonPorter Old Dude

    Joined:
    Feb 25, 2001
    Messages:
    2,690
    Likes Received:
    1,599
    Occupation:
    Geological Tech (2nd career after 30+ years in IT)
    Location:
    Lake Orion, MI
    Home Page:
    Go with a Duralast Gold from AZ. They are cheap enough to not have to mess with a crappy battery.
     
    Bob Gervais likes this.
  5. JRA2000TL

    JRA2000TL The Complainer

    Joined:
    Dec 29, 2006
    Messages:
    1,665
    Likes Received:
    712
    Occupation:
    Internal Auditor
    Location:
    Daphne, AL
    You know..now that I think about it, especially in these cooler months, I bet this crappy battery is why my car has hard starts after it sets up. The PO replaced the fuel filter and cam sensor, and the fuel pump primes. It starts OK after it's warmed up. Either I have a fuel pump going out or this sorry battery is losing its cranking amps. On a cold start I have to hold the key for a long time and sometimes it still doesn't start the first try. I feel like going to swap it out now even though it's still good...it's junk in my book though.
     
  6. RonPorter

    RonPorter Old Dude

    Joined:
    Feb 25, 2001
    Messages:
    2,690
    Likes Received:
    1,599
    Occupation:
    Geological Tech (2nd career after 30+ years in IT)
    Location:
    Lake Orion, MI
    Home Page:
    Go for it, it's a cheap, easy fix.
     
  7. tompumped

    tompumped SHO Member

    Joined:
    Jan 14, 2006
    Messages:
    486
    Likes Received:
    56
    Location:
    VT
    I found out, from this forum, that you could also have the wrong starter in the car. If you have a starter motor with less teeth on the drive gear it will result in hard starting occasionally.
     
  8. JRA2000TL

    JRA2000TL The Complainer

    Joined:
    Dec 29, 2006
    Messages:
    1,665
    Likes Received:
    712
    Occupation:
    Internal Auditor
    Location:
    Daphne, AL
    Yeah not sure which one's on it even though I just had the thing out when I replaced my rod bearings. The ATX models have a different starter than the MTX models, so it's possible.
     
  9. RAYJAY

    RAYJAY WHO ME ?

    Joined:
    Apr 13, 2005
    Messages:
    1,276
    Likes Received:
    104
    Occupation:
    NEWS PAPER PRESSMAN
    Location:
    UNION DALE PA
    Home Page:
    look for a interstate battery dealer, i get all my battery's there. for $35.00 bucks a pop for a blem battery its a great deal

    jeff
     
  10. Bob Gervais

    Bob Gervais Wut?

    Joined:
    Sep 6, 2002
    Messages:
    2,516
    Likes Received:
    2,348
    Occupation:
    Facilities Manager
    Location:
    Westerly, RI
    Home Page:
    This right here. My SHO and the truck both have them. I replaced the one in the SHO under warranty last year, no issues at all returning it.
     
  11. JRA2000TL

    JRA2000TL The Complainer

    Joined:
    Dec 29, 2006
    Messages:
    1,665
    Likes Received:
    712
    Occupation:
    Internal Auditor
    Location:
    Daphne, AL
    $108 later, I have the Duralast Gold DL-34G in the white car now. Starts up better and the econo-crap is gone. I coulda used that extra $108 for something else but oh well; I drive the 95 quite a bit now.
     
    SHOMON and Bob Gervais like this.
  12. SHOMON

    SHOMON 95 MTX

    Joined:
    Aug 15, 2006
    Messages:
    456
    Likes Received:
    32
    Location:
    MEDWAY MASS.

    I replaced my az gold battery once for free, and then only paid 35 bucks the second time under the pro rated warranty.
     
  13. tompumped

    tompumped SHO Member

    Joined:
    Jan 14, 2006
    Messages:
    486
    Likes Received:
    56
    Location:
    VT
    I'm not trying to start an argument, but. Both of you had to replace your "Gold" battery from autozone. I know a few people personally that have had problems too.
    My first legend battery was in my firechicken with a carbureted high performance small block chevy before my sho. More than once I had to crank the car for a long period from ignition problems one time and flooding bad a couple times. It was amazing how long the battery lasted. I've never seen a battery last that long. It did drain down a number of times though from sitting and cranking
    Then when I got my sho I installed it and it lasted with no issues for a year and a half until I hit a deer. Believe it or not it still started my car days later and more than 3/4 of the fluid drained out.
     
    Last edited: Dec 29, 2010

Share This Page

If you wish to help keep SHOforum running, please click the donation button below