EGR failure symptoms !

Discussion in 'Gen 1 & 2 - Emergency Issues - Help & Maintenance' started by mylaw, Mar 22, 2007.

  1. mylaw

    mylaw The Sho Time

    Joined:
    Jul 25, 2006
    Messages:
    143
    Likes Received:
    0
    Location:
    Ottawa
    I changed DPFE sensor and cleaned the nostrils in the intake they were plugged and car still idles low and stalls when cold .. Lack of power..
    I did the suck test on the egr hose and the engine did not change at all .. Faulty EGR?
    Can anyone shed some light on this .... Thank You
     
  2. jedhead

    jedhead SHO Member

    Joined:
    Nov 25, 2001
    Messages:
    2,545
    Likes Received:
    188
    Occupation:
    Account Manager
    Location:
    westminster,ca
    Home Page:
    Did you pull codes? My failing EGR only causes some light pinging at 2000 - 3000 rpm other wise no other problems. Your problem maybe related to something else.

    Bob
     
  3. mylaw

    mylaw The Sho Time

    Joined:
    Jul 25, 2006
    Messages:
    143
    Likes Received:
    0
    Location:
    Ottawa
    332, 326, codes
    the egr i believe is stuck closed !
     
  4. St Louis SHO

    St Louis SHO Rollin' coal Staff Member

    Joined:
    Nov 16, 2006
    Messages:
    4,621
    Likes Received:
    2,820
    Occupation:
    Master Baiter
    Location:
    0 .· ` ' / ·. 150
    Home Page:
    EGR stuck open would cause the problems you describe. Did you check the vacuum at the valve to make sure the Sol. isn't stuck open?

    James
     
  5. mylaw

    mylaw The Sho Time

    Joined:
    Jul 25, 2006
    Messages:
    143
    Likes Received:
    0
    Location:
    Ottawa
    I did the suck test and the engine idle did not change ! How do I check the SOl
     
  6. St Louis SHO

    St Louis SHO Rollin' coal Staff Member

    Joined:
    Nov 16, 2006
    Messages:
    4,621
    Likes Received:
    2,820
    Occupation:
    Master Baiter
    Location:
    0 .· ` ' / ·. 150
    Home Page:
    pull the vacuum hos off of the egr valve and see if it has suction at idle
     
  7. mylaw

    mylaw The Sho Time

    Joined:
    Jul 25, 2006
    Messages:
    143
    Likes Received:
    0
    Location:
    Ottawa
    it does not have suction at all at idle
     
  8. SHOZ123

    SHOZ123 SHO Member

    Joined:
    Dec 2, 2000
    Messages:
    12,045
    Likes Received:
    574
    Occupation:
    Industrial Electrician
    Location:
    40:52:43.6 N 87:50:47.447
    Home Page:
    Then sounds like the valve itself has debris or something keeping it open. When started cold and letting it idle does the pipe going to the EGR valve get hot?
     
  9. mylaw

    mylaw The Sho Time

    Joined:
    Jul 25, 2006
    Messages:
    143
    Likes Received:
    0
    Location:
    Ottawa
    I fixed everything. I welded the crank timing gear to the crank set the timing because it was way off.
    Car seams to be running really good now...

    Thanks for all your help evryone////
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below